CDN Issues
Incident Report for BuzzFeed
Resolved
Our CNS provider has resolved the issue.
Posted almost 2 years ago. Oct 25, 2016 - 15:37 EDT
Monitoring
Our provider has let us know that they're experiencing problems on their end. We are working with them. In the meantime, browsing the site might be slower and some elements might not load correctly.
Posted almost 2 years ago. Oct 25, 2016 - 15:30 EDT