Post Update Delays
Incident Report for BuzzFeed
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 12, 2017 - 19:31 EDT
Investigating
Some posts are not updating immediately after the updates are added in and the post is republished. We have a lead on the problem and are currently investigating the underlying issue.
Posted 10 months ago. Sep 12, 2017 - 15:55 EDT