hp site outage
Incident Report for BuzzFeed
Resolved
buzzfeed.com home page should be back!
Posted Jul 17, 2019 - 02:56 EDT
Investigating
we're currently having a site issue on buzzfeed.com home page.
Posted Jul 17, 2019 - 02:38 EDT
This incident affected: BuzzFeed.com.