BuzzFeed's app is a little under the weather!
Incident Report for BuzzFeed
Resolved
BuzzFeed is backing to feeling like our old self! Look out for great load times and even better content, but please let us know if you continue to notice any hiccups by emailing support@buzzfeed.com or reaching out to us on Twitter @BuzzFeedSupport 🙏
Posted 8 months ago. Oct 05, 2017 - 17:40 EDT
Identified
Our app isn't feeling like it's best Beyonce, and you may notice it performing a little less fabulously than usual, like by closing unexpectedly! We're working hard to get this sorted ASAP + cannot thank you enough for your help as we get back on track! 😰😷❤️
Posted 8 months ago. Oct 05, 2017 - 16:16 EDT