BuzzFeed Search is currently experiencing some difficulties
Incident Report for BuzzFeed
Resolved
This incident has been resolved.
Posted over 1 year ago. Jul 05, 2017 - 16:04 EDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Jul 05, 2017 - 15:37 EDT