Some Pages Not Loading
Incident Report for BuzzFeed
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 23, 2016 - 14:28 EDT
Investigating
We are currently investigating sporadic loading errors on some BuzzFeed pages. We will notify you once the outage is resolved.
Posted over 1 year ago. Aug 23, 2016 - 13:22 EDT