Intermittent Site Issues
Incident Report for BuzzFeed
Resolved
We have resolved the sporadic loading errors on some BuzzFeed pages. Please let us know if you continue to experience issues.
Posted almost 2 years ago. Sep 28, 2016 - 17:43 EDT
Identified
We have identified the cause of the sporadic loading errors on some BuzzFeed pages. We will notify you once the outage is resolved.
Posted almost 2 years ago. Sep 28, 2016 - 17:00 EDT