Android App
Incident Report for BuzzFeed
Resolved
Thank you for your help and patience as we got this sorted; we're so lucky to have users like you!!!
Posted over 1 year ago. May 02, 2017 - 17:54 EDT
Identified
Android App users on KitKat or less recent Operating Systems may notice some wonkiness in the BuzzFeed app; we've identified this issue and are actively working to resolve it. Thanks for your help and patience as we get this sorted!!
Posted over 1 year ago. May 02, 2017 - 17:26 EDT